Research Station CRASH! Please Help


New member
Just went to take a break from doing quests today and work on my outpost and spacesuit researched (I've maxed out weapons). Game crashed immediately when I clicked on the research station in the Lodge.

I made sure I had the latest AMD Adrenaline and NVidia drivers. I tried the station on my ship --> same thing. Game shuts down immediately upon clicking on the station to access it.

Currently I'm running:

Win 11 Pro 64
AMD Ryzen 9 7950 X3D
Asus TUF RTX 4090
64gb Expo RAM
SK Hynix 2 TB NVMe 4th Gen (x 2) and Samsung 990 Pro 2TB NVMe 4th Gen (game drive)
On a 500mb/s Up/Down fiber internet connection...

Thanks for any help you can give! I love the game and really enjoy gathering materials and crafting; my poor ship looks like a floating cargo container transport, lol! I'd hate to have to stop playing because of this....


Ok, for those who search and find this thread, there's a fix that is SOooo easy:

Just validate your Steam files under properties after you right-click. Found a corrupted file, which it fixed. Problem solved! Yay!!